Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 15, 2024 - 06:35 EDT
Scheduled
We are performing scheduled maintenance to our infrastructure. The web application and client portal will briefly be unavailable. The mobile application will continue to work and inspections may be performed, but data cannot be backed up on the server until maintenance is completed.
Posted Sep 15, 2024 - 06:34 EDT
This scheduled maintenance affected: TI Web Application & Client Portal and Report PDF Generation.