AWS appears to have resolved issues affecting our service and the system is now operating normally.
Posted Oct 20, 2025 - 16:26 EDT
Update
We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 14:58 EDT
Monitoring
Our hosting partner, Amazon Web Services, is experiencing degraded performance today and they have not been able to allocate as many computing resources to our service as we require. As a result, the system may appear to be operating slower than normal especially as the peak work hours approach. We will continue monitoring the situation and update you here as things improve.
Posted Oct 20, 2025 - 11:40 EDT
This incident affected: TI Web Application & Client Portal, Mobile Application, and Report PDF Generation.